Silhouette Studio Tools Not Working?

Hey Friends. Anyone here with a Silhouette? I have a Silhouette Cameo 3. I haven’t used it in months, as we moved, so it was packed. We kept it with us in the rental house (rather than put it in a freezing cold storage unit in the dead of winter where it could be damaged by cold), and now moved it into our new place.

When I started up Silhouette Studio today, I could used the tools. Specifically Text, which I used to write a word I wanted to cut. But when I went to the Send Tab, it was showing my machine as ‘not available’. Actually, it was showing 3 of my identical machine as ‘not available’. I remembered that since I usually have months between using it, it seems like each time I go to do so, I need to update the software. So I updated the software, assuming it would then ‘find’ my machine. I had no problem updating the software, but now none of the Tools work. If I click on the Text tool, then go to write anything, it deselects the Text Tool and goes back to the Arrow (move) tool. I did try dragging the tool to create a text box, and right clicking, and everything else I have ever done in any other design type software, but no dice. I then tried writing my word in another program, to see if I could take a screen cap, and then turn that into a cut file by selecting the area. Nope. None of the Tools will let me do anything.

Has anyone else run into this?

I did try deleting the software and reinstalling it. And I updated my Mac, and restarted that twice.

Did you update to Ventura? I don’t have a silhouette so I can’t be helpful there but I know Ventura has caused some issues with weaving software I use.

1 Like

I eventually found a tutorial on how to download a previous version of the Silhouette software. The person recommended a specific version of the Studio that was the least buggy, so I went with that. Once the new version was gone, and I was with an old one, the tools all worked again as usual. :woman_shrugging: