I cannot load photos

I cannot seem to load certain photos. I have changed the size of the jpg and even tried a gif. Then I went on my phone and tried as well. I keep getting a notice saying "
Permission denied @rb_sysopen -
/var/www/discord/tmp/downlaod_cache/cdcc (and then a bunch more that runs off the screen).
I can’t even take a screen shot of it and post it to show here.
Is this happening to anyone else?

1 Like

The same thing is happening for me with multiple different images and file types.

Permission denied @ rb_sysopen - /var/www/discourse/tmp/download_cache/27ae64b1247306b44de5703de15a86e59b25a1a9.jpeg

It seems to work when I try to upload a picture I’ve already uploaded before. Example:


Same here, although like jellybean I can do previously used photos. I also had to log in this morning, which leads me to believe there have been updates run recently.

ETA: I’m on an Android phone running the Samsung Internet app.


I had to log in too. & can’t upload a photo, just tried it.


I’m getting the same error when trying to upload a photo.

1 Like

Yes, I could load a picture that I previously loaded, but nothing new. I even tried to copy a photo that someone else took and load it, didn’t work.


I had to log in this morning. I have not tried to upload images.

I got logged out of all my devices and couldn’t upload photos yesterday but today seems to be working better

I got logged out on both of my devices too.

I tried logging out and logging back in. No improvement.

I just tried to upload and got the same error message. Is there some kind of space limit that we’ve hit? It’s weird that you would still be able to upload pics you have already uploaded before.

I don’t think it’s a space issue given the permission error. I think what’s actually happening is

  • there was an upgrade
  • the upgrade pointed to a folder which the user running the software doesn’t have access to write to
  • when an image is uploaded, there is some sort of hashing algorithm that is ran so if you try to upload the same image, it doesn’t actually upload it a second time, it just uses the existing one
  • the user discourse is running as just needs to be given write permissions to the temp directory where image uploads are stored

I’m having the same issues – I had to login this morning and just now was unable to upload a photo (and it was so pretty, too!).

Well that explains it :thinking:

1 Like

I had to log in this morning too. I’ve noticed several wonky things the last week, which makes me think things are happening behind the scenes. Hopefully they get straightened up soon.

1 Like

I also got logged out of my devices today. I haven’t tried uploading photos.

Aha! I should have looked for this thread before i tried to upload photos a dozen times this evening. :joy:


I was told it would be fixed today. Don’t fret. They are working on it behind the scenes! :tada:


I forgot and just tried a picture but didn’t work so I’ll try to patiently wait …


Yes, working on it! :slight_smile: Working on some updates and got a few hiccups. :upside_down_face: